Konfigurasi DHCP Server dengan Multiple VLAN Cisco Packet Tracer

Dynamic Host Configuration Protocol (DHCP) adalah protokol yang berbasis arsitektur client/server yang dipakai untuk memudahkan pengalokasian alamat IP dalam satu jaringan. Sebuah jaringan lokal yang tidak menggunakan DHCP harus memberikan alamat IP kepada semua komputer secara manual. Jika DHCP terpasang pada jaringan lokal, maka semua komputer yang tersambung pada jaringan akan mendapatkan alamat IP secara otomatis dari server DHCP. Selain alamat IP, DHCP juga memberikan parameter seperti default gateway dan DNS server.

VLAN memungkinkan jaringan untuk disegmentasi dan dibentuk menjadi kelompok logis pengguna, terlepas dari lokasi fisik pengguna atau koneksi LAN.

Pada tutorial ini, kita akan melakukan konfigurasi sebagai berikut:

  • Buat 3 VLAN dan tambahkan PC pada setiap VLAN
  • Konfigurasi DHCP Server pada Router
  • Assign DHCP Pool pada setiap VLAN
  • Konfigurasi PC sebagai DHCP Client
  • Tes Koneksi

Konfigurasi VLAN pada Switch

Buat 3 VLAN pada switch : VLAN 10, VLAN 20 dan VLAN 30.

Switch#en
Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#

Tetapkan port VLAN 10 pada interface Fa0/1, VLAN 20 pada interface Fa0/2, VLAN 30 pada interface Fa0/3 dan pada interfaceFa0/4 (interface yang terhubung ke router) tetapkan mode TRUNK.

Switch>en
Switch#conf t
Switch(config)#int fa0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int fa0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#int fa0/3
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#int fa0/4
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Cek VLAN yang telah anda buat.

Switch#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig0/1, Gig0/2
10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2
30   VLAN0030                         active    Fa0/3

Cek interface mode trunk

Switch#sh int trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa0/4       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/4       1-1005

Port        Vlans allowed and active in management domain
Fa0/4       1,10,20,30

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/4       1,10,20,30

Konfigurasi DHCP Server pada Router

Langkah pertama yang kita lakukan adalah melakukan konfigurasi interface pada router. Pada contoh di atas, Router terhubung dengan switch pada port Gi0/0. Pada interface Gi0/0, kita buat 3 subinterface yaitu : Gi0/0.10, Gi0/0.20 dan Gi0/0.30 dengan ip 192.168.10.1, 192.168.20.1 dan 192.168.30.1.

Router#en
Router#conf t
Router(config)#int Gi0/0
Router(config-if)#no ip add
Router(config-if)#no shut

Router(config-if)#int Gi0/0.10
Router(config-subif)#
Router(config-subif)#en dot1q 10
Router(config-subif)#ip add 192.168.10.1 255.255.255.0
Router(config-subif)#exit

Router(config)#int Gi0/0
Router(config-if)#int Gi0/0.20
Router(config-subif)#en dot1q 20
Router(config-subif)#ip add 192.168.20.1 255.255.255.0
Router(config-subif)#exit

Router(config)#int Gi0/0
Router(config-if)#int Gi0/0.30
Router(config-subif)#ip add 192.168.30.1 255.255.255.0
Router(config-subif)#exit
Router(config)#

Selanjutnya konfigurasi dhcp server sebagai berikut.

Router#en
Router#conf t

Router(config)#ip dhcp pool POOL10
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.10.1

Router(config)#ip dhcp pool POOL20
Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.20.1
Router(dhcp-config)#
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.20.1

Router(config)#ip dhcp pool POOL30
Router(dhcp-config)#network 192.168.30.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.30.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.30.1
Router(config)#

Konfigurasi PC sebagai DHCP Client

Klik tab “Desktop”, kemudian pilih “IP Configuration”.

TOP TUTORIALS:  Cara mengaktifkan TPM 2.0 Windows 11

Pilih “DHCP” (1), jika berhasil akan ada notifikasi “DHCP request successful” (2). Selanjutnya pada point (3) akan ditampilkan ip dan parameter lainnya dari DHCP Server.

Tes Koneksi

Untuk melakukan tes koneksi, anda bisa melakukan ping dari PC0 (192.168.10.2) ke PC1 (192.168.20.2)

Tinggalkan Komentar

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *